Kopano Files: Konfigurations-UI wird nicht angezeigt

UCS Mailstack (Handbuch)

Kopano Files: Konfigurations-UI wird nicht angezeigt

Postby tobiaslorentz » Sun 22. Jan 2017, 15:06

Hallo,

ich hab vor kurzem auf Kopano gewechselt und prinzipiell funktioniert auch alles. Ich habe nur ein Problem mit dem Web-App.
In den Einstellungen für "Files" versuche ich eine neue Account anzulegen und bekomme hierfür auch das entsprechende Popup.
Nach der Auswahl der Servers erscheint jedoch darunter nicht das Formular um Server, Benutzername etc. einzutragen.
Ich hab mir mal die HTTP Kommunikation angesehen und da werden dynamisch die Formulardaten angefragt, jedoch nicht angezeigt:
Es wird hier folgende Url abgerufen: https://<server>/webapp/plugins/files/php/backendFormConfig.php?backend=Owncloud&_dc=1485090177657
Ergebnis:
Code: Select all
{"success":true,"metaData":{"fields":[{"name":"server_address","fieldLabel":"Server address","editor":{"allowBlank":false}},{"name":"server_port","fieldLabel":"Server port","editor":{"ref":"../../portField","allowBlank":false}},{"name":"server_ssl","fieldLabel":"Use SSL","editor":{"xtype":"checkbox","listeners":{"check":"Zarafa.plugins.files.data.Actions.onCheckSSL"}}},{"name":"server_path","fieldLabel":"Webdav base path","editor":{"allowBlank":false}},{"name":"user","fieldLabel":"Username","editor":{"ref":"../../usernameField"}},{"name":"password","fieldLabel":"Password","editor":{"ref":"../../passwordField","inputType":"password"}},{"name":"use_zarafa_credentials","fieldLabel":"Use Kopano credentials","editor":{"xtype":"checkbox","listeners":{"check":"Zarafa.plugins.files.data.Actions.onCheckCredentials"}}}],"formConfig":{"labelAlign":"left","columnCount":1,"labelWidth":80,"defaults":{"width":292}}},"data":{"server_address":"demo.owncloud.org","server_port":"80","server_path":"/remote.php/webdav"}}


Ich verwende Chromium auf Ubuntu in der Version 55.0.2883.87.
Anbei auch ein Screenshot.

Mit freundlichen Grüßen

Tobias Lorentz
Attachments
Bildschirmfoto vom 2017-01-22 14-05-47.png
Screenshot
tobiaslorentz
 
Posts: 27
Joined: Sun 6. Sep 2015, 19:02

Re: Kopano Files: Konfigurations-UI wird nicht angezeigt

Postby fbartels » Mon 23. Jan 2017, 08:41

Hallo Tobias,

so wie es aussieht scheint dort das Popup nicht erweitert zu werden. Ich würde dich bitten dein Problem einmal im Kopano Forum zu beschreiben, damit sich das jemand aus unserem WebApp Team ansehen kann. Das (neue) Forum findest du unter https://forum.kopano.io/category/21/kop ... pp-plugins
User avatar
fbartels
 
Posts: 280
Joined: Wed 18. Dec 2013, 17:51
Location: Hannover/Delft


Return to Mail

Who is online

Users browsing this forum: fbartels and 1 guest