User in Open-Xchange

UCS Mailstack (Handbuch)

User in Open-Xchange

Postby janosch12 » Tue 3. Jan 2017, 12:17

Hallo,
ich versuche seit einer Weile einen User in UCS für OX anzulegen,
es hängt aber nur an diesem einen User, andere User funktionieren.

entweder erhalte ich die Meldung das der User im OX Content nicht verfügbar sei, oder nach dem Einloggen erhalte ich die Meldung: Fehler bei Authentifizierung .. ( Siehe Screen )

ich habe den User eben mit einer anderen Email Adresse angelegt, siehe da es funktioniert, Emailadresse evtl doppelt ?
welcher Log Bericht ist es genau im Ordner var/log ?

gerne gebe ich dann weitere Informationen.
Attachments
serverdiscounter-fehler.PNG
janosch12
 
Posts: 6
Joined: Fri 15. Apr 2016, 17:21

Re: User in Open-Xchange

Postby troeder » Tue 3. Jan 2017, 13:09

Hallo,

vermutlich trat ein Fehler bei der Synchronisation von UCS (LDAP) zu Open-Xchange (SQL) auf. Dafür zuständig sind sogenannte Listener-Module. Deren Logdatei ist /var/log/univention/listener.log
Open-Xchange selbst loggt nach /var/log/open-xchange/*.log

Primäre E-Mail-Adressen müssen immer einzigartig sein. Wenn Sie diese Prüfung nicht explizit abgeschaltet haben, lässt sich einem Benutzer keine bereits verwendete E-Mail-Adresse zuordnen.

Um alle Benutzer zu finden, die eine bestimmte E-Mail-Adresse verwenden, suchen Sie so:
Code: Select all
univention-ldapsearch -xLLL '(|(mailPrimaryAddress=EMAIL@DOMAIN)(mailAlternativeAddress=EMAIL@DOMAIN))' dn uid mailPrimaryAddress mailAlternativeAddress


Gruß
Daniel Tröder
User avatar
troeder
Univention Entwicklung
 
Posts: 210
Joined: Wed 20. May 2015, 16:40

Re: User in Open-Xchange

Postby janosch12 » Tue 3. Jan 2017, 13:32

Dankeschön,
habe den Fehler gefunden, bin mir nur noch nicht sicher wie ich diesen beheben kann :D

Der User wurde damals mit einem Tippfehler im Benutzername angelegt, und seit dem der Benutzername korrigiert wurde ( es fehlte ein P ) gibt es das Problem,

Lege ich nun den falschen Benutzer mit dem damaligen Passwort wieder an geht alles, ist ja allerdings nicht sinn der Sache.

Habe den falschen Benutzer dann noch einmal über die Oberfläche gelöscht, leider ohne Erfolg.
janosch12
 
Posts: 6
Joined: Fri 15. Apr 2016, 17:21

Re: User in Open-Xchange

Postby troeder » Wed 4. Jan 2017, 11:58

Ich kann aus der Beschreibung noch nicht sicher das Problem lesen, aber hier sind ein paar Mittel um dem auf die Spur zu kommen, bzw. um wieder einen konsistenten Zustand herzustellen:

Wenn Sie vor der Installation der OX-App die UCR-Variable ox/context/id nicht gesetzt haben, so ist der verwendete Kontext immer 10. Ich gehe im folgenden davon aus.

Um alle Benutzerkonten zu listen die OX kennt, verwenden Sie den Befehl:
Code: Select all
/opt/open-xchange/sbin/listuser -c 10 -A oxadmin -P "$(cat '/etc/ox-secrets/context10.secret')"

Wollen Sie alle Details kennen, können Sie noch "--csv" anhängen und die Ausgabe in eine CSV-Datei umleiten.
Die Spalte "Name" entspricht dem Linux/LDAP "username".

Wenn es nicht Probleme bei der (Einweg: UCS->OX) Synchronisation gab, so sind Dateien die in etwa so heißen: 1483369057.1866469383 unter /var/spool/univention-directory-listener/ox-* zu finden. Bitte fassen Sie diese nicht an, sondern berichten Sie hier in welchen Verzeichnissen es welche gibt.

Die E-Mails werden vom IMAP-Server Dovecot oder Cyrus verwaltet. Bitte prüfen Sie, welche Software Sie verwenden:
Code: Select all
ucr get mail/dovecot
ps ax | egrep 'dove|cyr'


Je nach dem, finden Sie die Mailboxen unter:
Code: Select all
/var/spool/dovecot/private/<domain>/<local-part of email>/
/var/spool/cyrus/mail/domain/u/uni.dtr/t/user/test1m/


Um zu prüfen ob ein Login per IMAP klappt (das ist es, was die OX-Web-Oberfläche am Anfang tut, und worüber sie sich am Screenshot beschwert), nutzen Sie am Besten fetchmail:
Code: Select all
ucr set repository/online/unmaintained=true
univention-install fetchmail
ucr set repository/online/unmaintained=false

fetchmail --check --nodetach --protocol IMAP --all --keep --username <email@domain> <external IP address of OX Server>

Mit "--verbose" druckt fetchmail den gesamten Protokollablauf.

Mit all diesen Informationen sollte es uns möglich sein, das Problem zu lösen.

Gruß
Daniel Tröder
User avatar
troeder
Univention Entwicklung
 
Posts: 210
Joined: Wed 20. May 2015, 16:40


Return to Mail

Who is online

Users browsing this forum: No registered users and 1 guest